bootcamp demo + own v3 server error

hi,

i installed photon on my other pc in the room next to me and i opened photon bootcamp demo i changed the "custom server adress" to ip:5055 and i run the game in the editor , i can enter my player name an then i come to the create room window i entered a name for the room and i clicked the create button.

But unity says in the debug log that it was unable to create the room, and that the game state is turned to disconnected

Does anyone knows what the problem might be ?

Comments

  • "can't launch Photon" might help
    What fixed it for me was this (also mentioned in the other thread)
    I ran
    lodctr /r
    
    from an administrative (elevated privileges) command prompt on Windows 7 x64.
    This helped fixed the issue noted in the logs as:
    CService::OnException() - Exception: CManagedHost::PhotonRunning() - Failed in AppDomain: 3 - Cannot load Counter Name data because an invalid index '' was read from the registry.
    

    EDIT: Quoting previously posted that section other readers may skip.
    I'm currently at:
    DebugReturn] Getting into game failed, client stays on masterserver: OperationResponse 227: ReturnCode: 32762 ([b]Failed to get server instance.[/b]). Parameters: {}.
    
    Post "Failed to get server instance" might help you as your server and client are on separate machines.

    For me, they're both on the same machine though.

    My logs have these three lines:
    5328: 16:03:24.402 - Forcing all applications ids to: "Master"
    5328: 16:03:24.402 - Forcing all applications ids to: "Game1"
    5328: 16:03:24.402 - Forcing all applications ids to: "Game2"
    
    Which seem related or make me think whether that is an issue? Does the server act as "Game2" only now?

    Later
    5328: 16:03:24.668 - Service is running...
    6644: 16:04:54.529 - CENetOutboundConnectionManager - OnReadCompletionError - An existing connection was forcibly closed by the remote host.
    

    The last log line is repeated every few minutes.

    My PhotonServer.config sets the IPAddress attribute to my LAN IP for every TCPListener and UDPListener (0.0.0.0 was causing listening on VPN and VMWare interfaces). I've set my Firewall application to Allow PhotonControl.exe and PhotonSocketServer.exe (both UDP and TCP)

    I also tried connecting from another machine Setting the UsePhoton object's CustomServerAddress to the LAN IP:Port setting. Rooms created when connecting from there also show the same issue.

    Post "Failed to get server instance", really had the solution.
    I think I initially tripped up on the comment "Leave empty and the the IP address will be looked up dynamically at runtime." in Photon.LoadBalancing.dll.config and left it set to 127.0.0.1
    Setting both, the value of, MasterIPAddress and PublicIPAddress to my LAN IP (and restarting PhotonControl > Photon InstaceLoadBalancing) fixed the issue. I'm now able to connect from both, a remote and local machine.
  • Thanks for this post, it fixed my issue.

    In case someone has this issue: The Photon-LoadBalancing log file has the error about the performance counters and restoring the performance counters from the backup with the command: lodctr /r fixed this error for me. I couldn't just reinstall the counters.
Sign In or Register to comment.