Catalina 10.15.6 PUN Permissions

Hi Everyone !

I have some problem when I build for MacOS 10.15.6 with Unity2019.3.15f1 and PUN 2.18.3:
Microphone doesn't work.
When I launch the .app produced by Unity after build, I can't hear any sound from my microphone.

Here is what I saw :
  • I tested with the demo contained into PhotonVoice/Demos/DemoVoicePun.
  • I tested with Unity Type and Microphone type with the same results.
  • Microphone is well detected in Editor and Build.
  • Microphone works in Editor Mode.
  • I tried to sign the app without better results
  • It works on Windows 10 in Editor and Build.

When I launch the build, MacOS does not prompt me the Microphone permission popup. Unity does it.
I tried to use this unity method :
yield return Application.RequestUserAuthorization(UserAuthorization.Microphone);
        if (Application.HasUserAuthorization(UserAuthorization.Microphone))
        {
            Debug.Log("Microphone found");
        }
        else
        {
            Debug.Log("Microphone not found");
        }
The permission prompt is not displayed but I see the log "Microphone found" in build logs.
Thanks in advance for your help.
Colin.


Comments

  • Hi @cboulanger,

    Thank you for choosing Photon!

    In player settings -> Other settings -> Configuration there is a field named "Microphone usage description". This needs to have a value so that Unity asks for the permissions
  • It works !
    Thanks a lot for your help @JohnTube !
    Have a nice day !
Sign In or Register to comment.