Temporarily 'Game full' while room still has space. Double counting joins?

I am hosting a photon server on my machine and using PUN 2 to connect clients to the server.

However, it seems that clients are double counting for a while (~10s) when they join a room.

Max players -> Max can join
2 -> 1
3 -> 2
4 -> 2
5 -> 3

I call 'JoinOrCreateRoom("Room", roomOptions, TypedLobby.Default)' to create/join the room, and from the client logs, I am sure that I only call this once.

What else could be happening?

Comments

  • hi, @Erethan

    could you try to use join for second player?

    from what server do you get this error from Master or from GameServer?

    best,
    ilya
  • I am not sure, but from the Logs, I would guess that clients are still on the master server when they get this error.

    GameFull.png

    I joined the room with up to 3 clients (counting with the Master client who created the room)

    Max players -> MasterClient -> Second client-> Third client
    2 -> OK -> 'Game full' -> x
    3 -> OK -> OK -> 'Game full'
    4 -> OK -> OK -> 'Game full'
    5 -> OK -> OK -> OK

  • I just realized you might have meant call JoinRoom instead of JoinOrCreateRoom for the other clients. I'm sorry.

    I checked that, and I the same issue occurs
  • When a room is created, 'OnRoomListUpdate' does say that there are 2 players inside that room. When another player joints, it increases to 4.

    If I wait for a while, this number halfes back to what it's supposed to be. However, if another client joins the room, this client will still count as 2 for a while
  • Activate debug logging on GS.
    It sounds like bug.
    Please collect the logs and send them to me. Are you using ExpectedUsers?

    best,
    ilya
  • I am not sure where exactly I am supposed to change to enable debugging on the GS.
    I've changed this config file:
    '...\deploy\Loadbalancing\GameServer\bin\log4net.config'
    at
    '<log4net debug="false">'
    to
    '<log4net debug="true">'

    But I saw no effect on 'deploy\log\GSGame.log'. However I am not sure if I changed the right file and if I am looking at the correct logs.

    Below gives some more info about logging but I could not figure it out on how to enable logging on the GS
    https://doc.photonengine.com/en-US/server/current/app-framework/logging#the_unmanaged_photon_socket_server_log


    Also, I am not using ExpectedUsers
  • yes, you found correct log4net.config

    it has this:
    <root>
    <level value="INFO" />
    <appender-ref ref="LogFileAppender" />
    <appender-ref ref="ConsoleAppender" />
    </root>

    INFO should be changed to DEBUG

    best,
    ilya
  • Hi @Erethan,

    Thank you for choosing Photon!

    I wanted to suggest using Photon Server v5 instead of v4 and the issue might already be solved there.
  • Once I get the chance, I will upgrade my Server then report back (and get the logs if the bug persists)

    Thanks @chvetsov & @JohnTube!
Sign In or Register to comment.