Deploy for Win32_xp

chvetsov mod
edited October 2010 in Photon Server
Hi, there.
I just downloaded new photon sdk. Version 2.2.
I use Windows XP 32 and try to start photon server from deploy/bin_Win32_xp
And it seems this version contains wrong PhotonSocketServer.exe. It tries to find InterlockedExchange64 in kernel32.dll. I check this exe with "depends.exe". It clearly shows that PhotonSocketServer.exe has wrong version


  • Tobias
    We need to reproduce this. As we don't use XP anymore it's a matter of finding time to set this up.
    I will send you a PM with a re-built version. If you're willing to give it a try, that would be appreciated.
  • Hello,

    I'm using Windows Server 2003 and I was always starting Photon via Win32_XP deploy but since I updated to 2.2 it throws me an error about not finding getTickCount64() function in Kernel32.dll.

    Could you please send me the re-built version on PM too or make this available here for public?
  • Tobias
    We just tested the new build with help of chvetsov and I am now uploading v2.2.1 as fixed release.
    If you are using Win2003 or Win XP to host Photon Server, get Photon Server SDK v2.2.1 here.
  • I re-built and re-deployed my project with the latest libs (2.2.1) but I get the following error:
    CService::OnException() - Exception: CManagedHost::StartApplication() - Failed to start application in AppDomain: 5 - Could not load file or assembly 'XXX.Server' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.
    It worked with 2.2.0 SDK and Win32 deploy but I'm trying to deploy it on XP mainly.
    Any suggestions, please?
  • Boris
    Several things to try:

    - make sure you have at least SP2 for windows xp installed

    - if your server does not have .net 4 installed:
    + make sure you have .net 3.5 SP1 installed
    + make sure VS is configured to compile everything for .net 3.5 or lower

    - if your server does have .net 4 installed but you want to run it with .net 2
    + add CLRVersion="v2.0" to the <Runtime> section of the PhotonSocketServer.xml

    - if you want to run your server with .net 4
    + make sure .net 4 is installed
    + add the following to the <configuration> node of your server.dll.config: <startup><supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0" /></startup>

    Hope that helps.
  • .NET 4 was missing somehow.. Now it works, thank you.