echo with android devices

halenhalen
edited June 2020 in Photon Voice
Hi,
We are developing application with photon voice. It's working well with headphones, but without headphones It was giving echo repeatedly.
when I tested in Sony Xperia with android 10 and asus with android 8 without headphone, It was giving echo repeatedly. But in other android devices with android 10 it's working well. I don't know what the problems were happen with these android devices? or I missed some setting?
In IOS devices, it's working fine

- microphone type : photon (have tried WebRtc when got echo but the result was the same)
- updated to latest Photon Voice 2 version.
- Unity Version - 2019.3.6f1
Please Help me.
Thanks

Comments

  • Hi @halen,

    Thank you for choosing Photon!

    with WebRtcAudioDsp I assume you tried "AEC Mobile".
    latest Photon Voice 2 I assume 2.17.

    as we explained here, we try our best to offer solutions to this problem but sometimes the hardware or the OS is limited and we cannot invest a lot to fix the issues in those areas.

    you can try adjusting some values in WebRtcAudioDsp but we can't promise the issues will go away or we can cover all devices.

    does other VoIP software work fine on the same devices?
  • Hi @JohnTube ,
    Other VoIP softwares : Skype, messager... are working fine on the same devices. I tried to test on Samsung galaxy. It was giving echo and on Xiaomi redmi worked fine.
    So i think that we should use headphones when we use our app on android. and on IOS devices, because it's working fine so we dont need.
    if you have any ideas, please tell me.
    Thank you very much.
Sign In or Register to comment.