Problem getting decent audio quality without echo on Pico Neo 2

howardorhowardor
edited June 2 in Photon Voice
We have a photon based app in which the audio is usually good in Oculus Quest, but problematic in Pico Neo 2 devices. We were eventually able to get rid of an echo back of our own voice, and interrupted signals (static and crackliness), but sacrificed some sound quality – sounding more like a radio voice than a regular voice. The following settings led to decent results, but still not the quality we’d prefer:

In Project Settings > Audio > System
Sample Rate set to 24000
Our Avatar Head prefab has AudioSource, PhotonVoiceView, Recorder, and Web Rtc Audio Dsp with the following settings in the inspector:
Recorder
Frame Duration = 20ms

Web Rtc Audio Dsp
AEC Mobile = true
ReverseStreamDelayMs = 120
AEC Mobile Comfort Noise = true
Noise Suppression = true
PhotonVoiceView
Has reference to the Recorder
autoCreateRecorderIfNotFound = false
In AvatarHead.Start() at runtime when PhotonInstantiated:
Recorder sampling rate = Sampling 8000
Recorder ReliableMode = true
ReactOnSystemChanges = true
(followed by call to recorderInUse.RestartRecording() )

The above settings provides us decent output with minimal echo on the Pico Neo 2. However we still seem to get an echo when we first speak which settles down after a few seconds.
Any other settings resulted in a great deal of echo back of our own voice or breaking up of the sound.
Can someone compare this to the settings use by other apps using Photon on Pico Neo 2 or similar devices? Are there other suggestion for improving sound quality while avoiding echo back?

Comments

  • Hi @howardor,

    Thank you for choosing Photon!

    We have these general instructions for "Echo or Noise".

    unrelated to echo:
    why do you change SamplingRate to 8000?
    why do you need reliable here? did you have issues without it?
    Pico Neo 2 or similar devices?
    What do you consider similar devices as we don't have Pico Neo 2 to test this.
Sign In or Register to comment.