Oculus Quest microphone detection

jeffries7jeffries7
edited May 20 in Photon Voice
The last few days I've been experimenting with PUN2, testing on desktop PC and Oculus Quest. Everything was working perfectly.
I then added Photon Voice 2 and again began testing between the editor and Quest, using the demo scene "DemoVoicePun-Scene".

Microphone detection within the editor was working fine. Building the scene onto the Quest I could hear the microphone input from the client running in the editor, however, the microphone from the Quest wasn't being detected.

The Quest was saying that 0 microphone inputs could be detected, I tried with and without the OVR library as well as changing the microphone type from Unity to Photon.

I then created a new project, adding Photon Voice 2 then adding PUN 2 after and no OVR library.
Building the same demo scene onto the Quest it then displayed 3 microphone inputs but no audio was being detected from the microphone. I then added the OVR library to the project, built for the Quest and it again returned 0 microphone inputs.

I'm not sure if there is something I'm missing when deploying onto the Quest, the permissions appear to be working correctly as I'm being prompted when opening the scene.

EDIT: I tested the LipSync Oculus demo which does work with the microphone.

Comments

  • It turns out the second time I'd run the application the microphone would work just fine. So something regarding granting microphone permission then immediately loading a scene that required the microphone was the issue.

    To fix this I put a loading scene before the required scene, this scene would request microphone permission (causing the permission pop-up window) and then load the actual scene that uses the microphone.
  • Hi @jeffries7,

    Thank you for choosing Photon!

    Did you check this out?
  • @JohnTube I've tried adding the permission requests into the manifest file myself as well as letting Unity do it automatically during the build process. I've also tested with different API levels.

    The only way to get the microphone permission pop-up is to have some code that tries to access the microphone.

    This is happening in Unity 2019.3
Sign In or Register to comment.