Photon server shut down immediatly after starting it

Hi,
I use Photon since a few month and everything worked right. After a short break from my project, i wanted to work on it again today. But when I start the photon server, it disconnects after a few seconds. I use the free license, so it doesn't expire. Somebody got a idea why the problem occurs? Heres a small piece form the log:

2168: 15:48:14.703 - Adding UDP listener on :127.0.0.1: 5056 with a listen backlog of: 500
2168: 15:48:14.703 - Forcing all applications ids to: "Game2"
2168: 15:48:14.703 - UDP address specified as:0.0.0.0 adding listener to each available IPv4 address
2168: 15:48:14.703 - Adding UDP listener on :192.168.178.20: 5057 with a listen backlog of: 500
2168: 15:48:14.703 - Adding UDP listener on :127.0.0.1: 5057 with a listen backlog of: 500
2168: 15:48:14.703 - Adding TCP Policy listener on :0.0.0.0: 843 with a listen backlog of: 150 and routing to application: "Policy"
2168: 15:48:14.703 - TCP inactivity timeout: 5000ms
2168: 15:48:14.765 - Service is running...
2168: 15:48:17.546 - CService::OnException() - Exception: CManagedHost::PhotonRunning() - Failed in AppDomain: 3 - Indikatornamensdaten können nicht geladen werden, da ein ungültiger Index "" aus der Registrierung gelesen wurde.
2168: 15:48:17.546 - Server shutting down...
2168: 15:48:17.546 - Notifying CLR applications of shutdown...
2168: 15:48:17.609 - Shutting down TCP Outbound Connection Manager...
2168: 15:48:17.609 - Shutting down ENet Outbound Connection Manager...
2168: 15:48:17.609 - Disconnecting all outbound peers...
2168: 15:48:17.609 - Shutting down ENet host...
2168: 15:48:17.609 - Disconnecting all peers...


Thanks for your help :).

Comments

  • We don't have the full logs but this points to a problem while loading an app.
    "Failed in AppDomain: 3"

    You could look up in the logs what app number 3 is. Maybe you should rebuild it with the SDK you want to run it in.
Sign In or Register to comment.