Photon Speaker not playing on Oculus Quest

Hi,

I'm using Photon Voice for an application on Oculus Quest (Android 7.1.1). I've follow this tutorial: https://doc.photonengine.com/en-us/voice/v2/getting-started/voice-intro / How To Use Photon Voice Without PUN.
I've enable the Debug Echo and it's working perfectly in Unity Editor but not in the Quest.

I looked at some values and see that Speaker.IsPlaying is true in Editor but false in Quest.
Does this looks like a known behavior ?

Thanks

Comments

  • JohnTubeJohnTube mod
    edited November 7
    Hi @Cedric_ModernStudio,

    Thank you for choosing Photon!

    Do you have microphone permission allowed for the application on Android?

    What are the values of each of these when you test w/ DebugEchoMode enabled:
    recorder.IsInitialized
    recorder.IsRecording
    recorder.TransmitEnabled
    recorder.IsCurrentlyTransmitting
    
    speaker.IsLinked
    I suggest you disable VAD (recorder.VoiceDetection = false) when testing.

    Could you reproduce with the demo scene "DemoVoiceMinimal-Scene"?

    What Photon Voice version are you using?
    What Unity version are you using?
  • edited November 7
    Hi JohnTube,

    I'm using Photon Voice v2.7 with Unity 2019.2.11f1 (I already had the issue when I was in 2018.3.14f1)

    Yes I allowed the microphone permission.

    The values you asked are:
    recorder.IsInitialized = true
    recorder.IsRecording = true
    recorder.TransmitEnabled = true
    recorder.IsCurrentlyTransmistting doesnt exist
    speaker.IsLinked = true 
    I have exactly the same behavior when I use the DemoVoiceMinimal-Scene.

  • Hi @Cedric_ModernStudio,

    Check the 3D settings of the AudioSource component attached to the same GameObject as the Speaker.

    There was a typo in the property name, it's IsCurrentlyTransmitting and not IsCurrentlyTransmistting.
    Anyway, I don't think it was added post 2.7.
    The speaker and the recorder are for the same player, one player only testing with DebugEchoMode only, right?

    Also, update to latest Photon Voice 2.
  • edited November 8
    Hi @JohnTube,

    I'm now using Photon Voice 2.11.
    The IsCurrentlyTransmitting is false.

    I'm mainly testing in your DemoVoiceMinimal-Scene, so I have only one player.
  • Check that the Quest avatar in your scene doesn't have lipSync on
  • Hi @Cedric_ModernStudio,

    Well, I thought it worked after you updated.
    Try disabling VAD (recorder.VoiceDetection = false) when testing.

    Also, make sure to wait until the client is joined to a room.
    Make sure the client is joined and not disconnected.

    And as @YanivClone mentioned, there could be some Oculus specific stuff.
    You can follow steps from this page.
Sign In or Register to comment.