Bolt Editor State Property changes not working for "Import Mecanim Modes->Replication Mode"

edited November 1 in BOLT Engine
Changing Import Mecanim Modes->Replication Mode->to "Local for each player"...doesn't appear anywhere in project.json.

When I re-open the Bolt State Editor, Import Mecanim Modes->Replication Mode is set back to the default "Everyone except Controller".

Answers

  • edited November 1
    Edit: using version 1.2.10
  • I'm able to work around this by hand-editing project.json with this line:

    "ReplicationMode": 4,
  • Hello @DrewProTag ,

    This option is used only when importing the variables from the Animation Controller, there is no need to serialize it, as it does is part of the State, that is why it goes back to the default value.

    The importer will set the current value of this option to the new imported properties.
  • Thanks @ramonmelo. The problem I was trying to fix was sending animation triggers via an event (instead of using the mecanim replication), but the non-controlled bolt entities did not play the animations (when calling GetComponent().SetTrigger(...). The controlled bolt entity (local) would play the animations though.

    I fixed it by hand-editing project.json with the line "ReplicationMode":4 for my bolt entity state. Is there a better way to fix this?
  • Hello @DrewProTag ,

    Can you send us a reproduction project showing this behavior to our email?
    [email protected]
  • @ramonmelo - repro project sent to [email protected]
Sign In or Register to comment.