Issue in Unity 2019.2.7

I'm having an issue when trying to import Photon Chat into a Unity 2019.2.7 project. At first it will work fine, but after a short period of time, usually after editing and compiling other scripts, Unity will be flooded with errors like this:
The type or namespace name 'EventSystems' does not exist in the namespace 'UnityEngine'
Basically tons of namespace errors referencing UnityEngine.UI and other core packages. Even if I remove all the Photon related files from the project, the errors will remain. The only way I've found to fix it is to remove the Photon files, close Unity, delete the Library folder, and re-open the project allow it to rebuild the Library folder.

It seems to me that this is an issue with the Photon plugin as I've found other plugins have had similar issues and have had to release updates to solve them. Any ideas?

Comments

  • JohnTubeJohnTube mod
    edited October 4
    Hi @Vcrn,

    Thank you for choosing Photon!

    What package did you import?
    Photon Chat or PUN2?

    Maybe asmdef is not configured properly or some packages were not imported?
  • JohnTube said:

    Hi @Vcrn,

    Thank you for choosing Photon!

    What package did you import?
    Photon Chat or PUN2?

    Maybe asmdef is not configured properly or some packages were not imported?

    I tried both Photon Chat from the Unity Asset Store, and the Chat SDK from https://www.photonengine.com/sdks
  • JohnTubeJohnTube mod
    edited October 11
    I could not reproduce this.
    here is a screenshot of demo scene running from Photon Chat 2.13 downloaded in a clean new fresh empty Unity 2019.2.8f1 project:

    As you can see EventSystem is there.
Sign In or Register to comment.