PhotonServerSettings missing after Cloud Build

I just updated to the latest version of PUN and Unity, and my Cloud Build EXE is no longer able to connect to the Photon cloud:

You did not select a Hosting Type in your PhotonServerSettings. Please set it up or don't use ConnectUsingSettings().

It seems that something is causing the PhotonServerSettings to go missing? I highlight them in my project, and everything looks correct, and I definitely have a Hosting Type set. I can still connect to the cloud from the Unity editor.
Any idea what might be causing this, or how I can fix it?

Comments

  • Hi @Zelek,

    It looks like PhotonServerSettings was created automatically on the Unity Cloud build because it was not found.
    So maybe it was not synchronized or copied over properly.
    Or it was removed.

    Double-check your VCS or Unity Collaborate settings, maybe that file is skipped or ignored.
    Or maybe the default Resources location folder is reserved or skipped/ignored.
  • JohnTubeJohnTube mod
    edited September 12
    You mentioned that you also updated Unity.
    Maybe it's the cause of this as the GUID files or assets database changes.

    So could you share with us the PUN and Unity versions before and after the update?
  • Hi John,

    Thanks so much for taking a look at this, I really appreciate it. After consulting with Unity Support this morning, it turns out the problem was related to a temporary outage in Cloud Build that they have now resolved. I just confirmed that my latest builds are once again working correctly and can connect to Photon Cloud.

    Thank you for your help!
  • Just a quick follow-up for anyone else who might run into this: the problem seems to result from selecting the "Clean Build" option in Cloud Build. Doing a normal build instead resolved the issue for me.
Sign In or Register to comment.