(Yet another) problem with using public IP

smooksmook
edited August 1 in Photon Server
Hi,

I know this quite a common problem but I've not been able to find a solution.

I am able to connect to the server if I have the server set to use local IP and my colleague is able to connect if I have the server set to use public IP. However, I cannot connect using my public IP if the server is set to use the public IP.

I have the photon server running on the same machine as my Unity installation using Photon PUN. I have forwarded all of the relevant ports listed here and have tried with both Windows firewall and my router firewall disabled.


Cheers

Comments

  • smooksmook
    edited August 1
    This is the output from the Unity console: https://gyazo.com/ee3e15092449108995fb43acec2532ef

    I'm not seeing anything appear in the Photon Control logs when I try and connect using the public IP.

    edit: Ok, if I have Photon control set to use public IP but I use my local IP in the server settings in Unity then I seem to be able to get at least a partial connection: https://gyazo.com/49a46bd5302dbd8018add4330a3c1c58 but it seems as though OnJoinedRoom() never gets called on the client.
  • Hi, @smook

    As I understand you are behind the router and trying to setup public addresses so that you both you and your friend are able to connect to the server. right?

    If I'm right, then all that I can say right now that it should work. I've tried few years ago with my keenetic_4g and managed to get it working. But it is hard to say what you should do to get it working b/c
    1. I do not know all the routers
    2. I do not remember how I did this for me

    It should not be rocket since. I'm sure you should be able to get it working

    best,
    ilya

Sign In or Register to comment.