Voice only working for some users

Hi, i'm using Photon Voice 2 and testing with 4-6 users (including me). Myself and one other person can hear each other fine, but the others in the room can't hear us or each other.

The logs show for those users it tries to initialise an empty microphone:
[Recorder.Recorder] [PV] MicWrapper: initializing microphone '', suggested frequency = 24000).
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 48)

[Recorder.Recorder] [PV] MicWrapper does not support suggested frequency 24000 (min: 44100, max: 44100). Setting to 44100
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 48)

[Recorder.Recorder] [PV] MicWrapper: microphone '' initialized, frequency = 44100, channels = 1.
It also shows that they should be connected to the voice network, so they should be able to hear us?
[GeneralSettings.PhotonVoiceNetwork] PUN joined room, now joining Voice room
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 48)

[GeneralSettings.PhotonVoiceNetwork] OnVoiceStateChanged from ConnectedToMasterserver to Joining
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 48)

[GeneralSettings.PhotonVoiceNetwork] OnVoiceStateChanged from Joining to DisconnectingFromMasterserver
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 48)

[GeneralSettings.PhotonVoiceNetwork] OnVoiceStateChanged from DisconnectingFromMasterserver to ConnectingToGameserver
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 48)

[GeneralSettings.PhotonVoiceNetwork] OnVoiceStateChanged from ConnectingToGameserver to Authenticating
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 48)

[GeneralSettings.PhotonVoiceNetwork] OnVoiceStateChanged from Authenticating to Joining
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 48)

[GeneralSettings.PhotonVoiceNetwork] OnVoiceStateChanged from Joining to Joined

Comments

  • JohnTubeJohnTube mod
    edited July 2019
    Hi @NyanBlade,

    The logs are normal.

    First, make sure PUN clients are connected to the same region (servers) and the same virtual application (AppId, AppVersion). Go through our "Matchmaking Checklist" carefully.

    The second thing you should do after verifying that clients can communicate with each other is to check if the PhotonVoiceView is setup properly (PhotonVoiceView.IsSetup, PhotonVoiceView.IsRecorder, PhotonVoiceView.IsSpeaker), Recorder is initialized (Recorder.IsInitialized), recording started (Recorder.IsRecording) and transmission enabled (Recorder.TransmitEnabled).
    You can log those values from PhotonVoiceView attached to the PUN prefab and PhotonVoiceView.RecorderInUse. PhotonVoiceView.IsRecorder needs to be true for the local player and PhotonVoiceView.IsSpeaker needs to be true for the remote player.
    The checks need to be done once the Voice client is joined to the room. (after "OnVoiceStateChanged from Joining to Joined")

    What Photon Voice 2 version are you using?
    If you are all testing from Unity Editor you could see debug info from PhotonVoiceNetwork component in play mode (see bottom foldouts).
    What is the target platform in case you test from builds?
Sign In or Register to comment.