Audio Processing DSP - Does it remove Echoes? Cannot seem to get it to work...

I have a very similiar issue to this recent forum posting:
https://forum.photonengine.com/discussion/13533/how-to-estimate-reversestreamdelayms-in-webrtcaudiodsp-of-photon-voice-2#latest


I have a lot of echoes when using speakerphone on cell phone devices with photon voice.
If I plug headphones into the phones, there is no echo, and you clearly hear the other party's voice, but when using the speakerphone, it becomes un-useable when both parties/more than one person is speaking and you record your voice while the speaker is playing their voice audio. (Example, in a conference call, so to speak. - Multiple people in the room, speaking at once.)
I have attempted to use the DemoVoice scene and my own scene with the WebRtcAudioDsp script, in test builds on Android phones but don't really notice a difference with the WebRtcAudioDsp script (still echoes very badly) , even when using Unity vs Photon Microphones. The WebRtcAudioDsp script has been added to the "Voice Connection and Recorder" GameObject in the DemoVoice Scene from Photon Voice 2 (unity plugin). I have examined the script and I believe it should be working with no further configuration.

Is there a way to verify that WebRtcAudioDsp script is actually scrubbing the audio? How can I move forward in making this work, so the echoes are removed?
Thanks for any input you might have...

Comments

  • Pointers I thought of since writing the first thread post:

    * Only using photon voice in project, no PUN files

    * VAT is used from the " Recorder " script, not from the WebRtcAudioDsp script

    * Tested with both Photon Voice server and Self-hosted server. Same resulting echoes using both server types. This is expected though.

    Any thoughts?
  • JohnTubeJohnTube mod
    edited July 2019
    Hi @JustinTimeStudio,

    Thank you for choosing Photon!

    What Photon Voice 2 version are you using?

    WebRtcAudioDsp component needs to be added to the same GameObject as the Recorder component being in use.

    Did you enable "AEC" or "AEC Mobile" from the WebRtcAudioDsp component?
    If you target Android or iOS enable "AEC Mobile".

    * VAT is used from the " Recorder " script, not from the WebRtcAudioDsp script
    You mean VAD: Voice Activity Detector which is not related to this issue.
    * Tested with both Photon Voice server and Self-hosted server. Same resulting echoes using both server types. This is expected though.
    This is a client issue not related to the server or networking.
  • Greetings,
    Version used: 2.8 from the AssetStore (unity) package.
    I have tried both AEC and AEC Mobile. Doesn't seem to affect the echoes, when either are in use.

    Would there be a way to see if the sound was being processed? Should it work well to eliminate echoes? Primarily, we're trying to setup a room/rooms, where all can talk at once, such as in a conference call, so to speak. When others are talking and your voice is recorded, the echoes appear.

    *** I also wondered, whether (when using speakerphone) muting the speaker, while recording, then unmuting upon voice recording (talking) is finished, might be a hack/work around?

    Thanks for your thoughts.

  • edited July 2019
    @JohnTube
    Any further thoughts? Just try again?
  • Hi @JustinTimeStudio,

    Games that want to provide a good audio experience recommend the usage of headphones right from the start of the app.

    Maybe the problem is not "echo" but something else like noise or VAD not calibrated.
    You can tweak WebRtcAudioDsp values and experiment with those.
    Sometimes the hardware is the problem and software can't solve this.

    We don't have other options to offer.
Sign In or Register to comment.