Photon Voice not recording

Hello,

I created a scene using Photon where each player is represented by a "proxy" Prefab that I instantiate and there is one local player who is linked to his own proxy Prefab.

I would like to add communication features to my scene : I added to the local player a Recorder and a Photon Voice Network Components and to the proxy prefab a photon voice view component as well as a speaker component.

However I can't manage to record any sound (transmit and isRecording are enabled) and my demo scenes are well working.

Could you help find out what issues am I missing ?

Thank you for your answers

Comments

  • Hi @ahaupa,

    Did you follow the workflow we have documented?

    What did you try?
    What do you see in the logs?
    What is the Photon Voice version you are using?
    How did you test this?
    What is the expected behaviour vs. the actual behaviour?
  • Hi @JohnTube,

    I reinstall Photon Voice and it is working fine now !
  • Sorry it is working on desktop but not in my headset !

    I tried the Photon Voice demo "DemoVoicePun" in my project and the microphone is well recording some sound but I can't hear anything when I apply the debug echo. I did the same test in another project and I can record and hear my voice very well.

    I guess this is a wrong audio settings.
    No Error logs appear and the level of the microphone is working but nothing in the speaker.

    I am using Photon Voice 2.8 with Unity 2018.3.6f1
  • Another thing : the sound is working in my headset for the 2 others demos. Just the demo "DemoVoicePun" is not working but I will have to use some components of it for my app
  • Hi @ahaupa,

    For DebugEcho to work:

    Recorder setup:
    - "Interest Group" needs to be 0
    - Transmission enabled ("Recorder.TransmitEnabled" set to true)
    - Recorder initialized (should be automatically initialized via PhotonVoiceView)
    - Recorder started (manual start via StartRecording or AutoStart enabled) also Recorder.IsRecording set to true

    Besides, PhotonVoiceView setup:

    - "SetupDebugSpeaker" enabled (set to true)
    - Recorder & Speaker properly setup (see workflow instructions)
  • Sometimes it works, something it doesn't work whereas I didn't change any parameters ..
Sign In or Register to comment.