Basic tutorial not work ("Lobby" part)

josecm
josecm
Hello, I am doing the Basic tutorial and I got an error in the Lobby part:
https://doc.photonengine.com/en-us/pun/v2/demos-and-tutorials/pun-basics-tutorial/lobby

I put all the code and when I hit Play, after the summary of Pings, it shows the following errors;
OperationResponse 230: ReturnCode: 32755 (Authentication type not supported). Parameters: {} Server: NameServer Address: ns.exitgames.com:5058
UnityEngine.Debug:LogError(Object)
Photon.Realtime.LoadBalancingClient:DebugReturn(DebugLevel, String) (at Assets/Photon/PhotonRealtime/Code/LoadBalancingClient.cs:2008)
Photon.Realtime.LoadBalancingClient:OnOperationResponse(OperationResponse) (at Assets/Photon/PhotonRealtime/Code/LoadBalancingClient.cs:2082)
ExitGames.Client.Photon.PeerBase:DeserializeMessageAndCallback(StreamBuffer) (at C:/Dev/photon-sdk-dotnet/PhotonDotnet/PeerBase.cs:619)
ExitGames.Client.Photon.EnetPeer:DispatchIncomingCommands() (at C:/Dev/photon-sdk-dotnet/PhotonDotnet/EnetPeer.cs:550)
ExitGames.Client.Photon.PhotonPeer:DispatchIncomingCommands() (at C:/Dev/photon-sdk-dotnet/PhotonDotnet/PhotonPeer.cs:1504)
Photon.Pun.PhotonHandler:FixedUpdate() (at Assets/Photon/PhotonUnityNetworking/Code/PhotonHandler.cs:116)
PUN Basics Tutorial/Launcher: OnDisconnected() was called by PUN with reason DisconnectByClientLogic
UnityEngine.Debug:LogWarningFormat(String, Object[])
Com.MyCompany.MyGame.Launcher:OnDisconnected(DisconnectCause) (at Assets/SCRIPTS/Launcher.cs:95)
Photon.Realtime.ConnectionCallbacksContainer:OnDisconnected(DisconnectCause) (at Assets/Photon/PhotonRealtime/Code/LoadBalancingClient.cs:3428)
Photon.Realtime.LoadBalancingClient:OnStatusChanged(StatusCode) (at Assets/Photon/PhotonRealtime/Code/LoadBalancingClient.cs:2489)
ExitGames.Client.Photon.<>c__DisplayClass103_0:<EnqueueStatusCallback>b__0() (at C:/Dev/photon-sdk-dotnet/PhotonDotnet/PeerBase.cs:906)
ExitGames.Client.Photon.EnetPeer:DispatchIncomingCommands() (at C:/Dev/photon-sdk-dotnet/PhotonDotnet/EnetPeer.cs:428)
ExitGames.Client.Photon.PhotonPeer:DispatchIncomingCommands() (at C:/Dev/photon-sdk-dotnet/PhotonDotnet/PhotonPeer.cs:1504)
Photon.Pun.PhotonHandler:FixedUpdate() (at Assets/Photon/PhotonUnityNetworking/Code/PhotonHandler.cs:116)

Any help please?

Comments

  • Hi @josecm,

    Thank you for choosing Photon!

    You have configured custom auth on the dashboard and


    - disabled anonymous auth (you unchecked "Allow anonymous clients to connect, independently of configured providers.")

    or

    - there is a line in your code that sets PhotonNetwork.AuthValues.AuthType to an auth provider type not configured on the dashboard

  • JohnTube said:

    Hi @josecm,

    Thank you for choosing Photon!

    You have configured custom auth on the dashboard and


    - disabled anonymous auth (you unchecked "Allow anonymous clients to connect, independently of configured providers.")

    or

    - there is a line in your code that sets PhotonNetwork.AuthValues.AuthType to an auth provider type not configured on the dashboard

    Great, now works enabling "Allow anonymous clients to connect, independently of configured providers". Seems that I used a previous created proyect some months ago, and I had set using Facebook login and disabled anonymous auth.

    Thanks!