Create Room On Cloud, No Problem. Create Room on Stand Alone Server... No Go :(

Will_CWill_C
edited June 23 in Photon Server
Hey guys, anyone have any idea what might be up here. I can easily connect and do whatever via the cloud, but on the stand alone server, i CAN connect to the master, but i can NOT create a room for the life of me. It doesn't even throw an error, nothing.

Its hosted locally, i'm connecting via 127.0.0.1. Connection makes it, but rooms just don't create.

I've disabled my firewall completely just to be sure, along with the port forwarded 5055 udp, 5056 tcp, but no luck.

TIA.

Comments

  • Ok, little progress regarding this.

    I have a question regarding running a private local photon server. Is there required configuration to allow public access?

    I notice that the ability to enable the server to use your public address is built right into the task bar control utility, but i have been reading as much as i can make sense of in the documentation, and it mentions things like, make sure only 1 game server is active (but insinutates that two are active in default config?), as well as setting things like MasterIPAddress in a config file...

    So, i am assuming that i can not just start the server with public IP address setup, and expect any results?

    If this is the case, would any one be kind of enough to run me through the basic setup here? The documentation is lacking a tutorial for the server specifics, and isn't exactly a step by step, but mostly foot notes and mentions of things.
  • Hi, @Will_C

    LoadBalancing configuration contains only one game server. So, when you start photon on one machine with default configuration you will get Master and GameServer running with default configurations which do not allow public connections.
    If you will start photon on another machine you have to update config so, then master does not start. Otherwise, you will have to masters.

    Photon.LoadBalancing.GameServer.GameServerSettings section of application config contains PublicIpAddress setting. You may use it to set the public address of your server explicitly. Update LoadBalancing/GameServer/bin/Photon.LoadBalancing.dll.config if you need to change public IP for GS.

    try built-in stardust client to check if your local setup works. if it does work. you may try to connect from an external address

    best,
    ilya
  • Will_CWill_C
    edited June 24
    Ahh yea. I have no issues with the server running locally and connecting locally. Just issues sorting out public server and connections. Still working on it. Thanks.

    Just to clarify though, (bit noobie here), i can not not launch the server as public, then connect from internally (locally) , no?

    I have tried using 192.169 etc.... 127.0.0.1, and even my external IP, but just can not connect to the server at all when it is using public IP address and i am local.
  • >Just to clarify though, (bit noobie here), i can not not launch the server as public, then connect from internally (locally) , no?

    it should be possible. That what you do when connecting to our public cloud. I assume there is some error in configuration.
    When you create game on master, Master takes accessible GameServer, gets its address and sends to client. If you fail to connect to GameServer then address which you get from master is wrong.


    best,
    ilya
  • Will_CWill_C
    edited June 29
    Yea, i'm pretty confused over this setup. I can easily get the server working locally with all settings local, and host local, but that seems to be default setup anyways.

    What I've done...

    Photon\Photon-OnPremise\deploy\Loadbalancing\GameServer\bin\PhotonLoadBalancing.dll.Config
    
          
          
            xxx.xxx.xx.xx
          
          
            60000
          
          
          
            4520
          
          
            xxx.xxx.xx.xx
          
    
    and i set the Bin\Mater\PhotonLoadBalancing.dll.Config values to the same as those above.

    I feel i'm doing this all terribly wrong, but i could not find a single walk through of setting this up for public IP anywhere. :( I did read documentation, but i couldn't find anywhere it got that detailed in setup for public, either.

    Thanks for reply though.
  • Hi, @Will_C

    What is your configuration? Where do you run/host your servers?

    best,
    ilya
Sign In or Register to comment.