The Photon Forum
is Closed Permanently.

After many dedicated years of service, we have made the decision to retire our Forum and switch to read-only: we´ve saved the best to last! Your search result can be found below. Plus, we offer support via these channels:

Try Our
Documentation

Please check if you can find an answer in our extensive documentation on PUN.

Join Us
on Discord

Meet and talk to our staff and the entire Photon-Community via Discord.

Read More on
Stack Overflow

Find more information on Stack Overflow (for Circle members only).

Write Us
an E-Mail

Feel free to send your question directly to our developers.

Two Different Websocket

Admir
2019-06-17 00:58:53

I'v come across a little problem, somehow 2 different versions of websockets are mixing after importing photon PUN 2 in my project.
http://prntscr.com/o2o5ca
This is because i have substance asset as well, which is pretty important for my project.

I have managed to fix this error by removing websocket-sharp.dll from the photon folder.
http://prntscr.com/o2or2m

Now my question is, will photon work with no problem with this dll removed? Is there a safer approach in solving this? I do not want to counter any future problem because i deleted this dll from Photon.

Thank you

Comments

JohnTube
2019-06-17 12:12:20

Hi @Admir,

Thank you for choosing Photon!

will photon work with no problem with this dll removed?
In theory yes, we didn't test this, however. I can see the versions of the 2 DLLs are different. I don't know about plugin platform settings in Unity Editor.

This is the first time we encounter this.
The substance asset that includes WebSocketSharp is this one?

Admir
2019-06-17 13:49:47

Thank you for quick reply @JohnTube,

Yes, that is the one, you can import that substance asset and photon PUN2 in the empty project and you will get the same error, just tested it again.

Admir
2019-06-17 13:58:01

I have also located another dll file from substance, after removing that one, problem is solved again.
http://prntscr.com/o2xnld

Maybe the better solution is to remove websocket from substance like this, so that photon won't show any troubleshoot in the future because of his own websocket-sharp.dll.

I will wait for your review on this then decide which dll to remove completly without breaking anything.

JohnTube
2019-06-18 10:48:21

Hi @Admir,

We recommend removing "Assets/Allegorithmic/Plugins/Substance/Livelink/Editor/Plugins/websocket-sharp.dll" (1.0.2.59611) and keeping "Assets/Photon/PhotonLibs/WebSocket/websocket-sharp.dll" (1.0.2.29661) as it's slightly newer.

Besides, Substance should not rely too much on this library, it is used in Editor only, maybe it has some account or sync feature required by Adobe (called "LiveLink"?).

Admir
2019-06-18 14:01:08

Thank you again for your feedback, the one from the substance is removed. Everything works fine now.

Have a nice day!

Back to top