Can't make Photon-PlayFab webhooks work

Guys, I am coming here after a few days of trying everything i could.
I am implementing a game with Corona, Photon and wanted to use Playfab for my User management.
The Corona Photon is working fine, I have tried the various example codes and they are working. My code is working up to getting the photon authentication tokne properly.
I have followed instructions to set the WebHooks up and I can make the call to the webhooks manually correctly
https://MYTITLEID.playfabapi.com/photon/authenticate?username=MYPLAYFABID&token=MYPHOTONTOKEN
the answer is then good

ResultCode 1
Message "Authenticated user 6a4d40c622d150ab title MYTITLEID"
UserId "6A4D40C622D150AB"
Nickname null

but when I create a room from any of the demo program or from my own code I always have the following error message

ERROR LoadBalancingClient: 32752 Failed to create game on https://MYTITLEID.playfablogic.com/webhook/1/prod/SECRETKEY/RoomCreated? : Error response ResultCode='2' Message='User not found'.

May be I am not using my authentication parameters correctly in my lua code ?
I have tried
client:setCustomAuthentication("username="..PlayFabId.."&token="..PhotonCustomAuthenticationToken)

Anyway, I am stuck out of ideas here.
Could anybody help me ?

philippe

Comments

  • Hi @PhilippeRenaut,

    Thank you for choosing Photon!

    Did you disable/untick/uncheck "Allow anonymous clients to connect, independently of configured providers" from custom auth. config.?

    Is authentication successful on the client?
    What is the UserId you have once authenticated?
  • edited March 18
    Hi I just did it now and now I have an error in the nameServer authentification :

    ERROR LoadBalancingClient: 3101 NameServer authentication failed (32755 Failed to parse token from request)
    Which is strange, i think i am using correctly the secret key at the end of the baseurl.
    I am not sure of the way to set up the userid, token authentication parameters in Lua though.

    The getphotonauthentication token seems to work -
    PlayFabId - 6A4D40C622D150AB
    15:17:54.832 PlayFab authenticated. Requesting photon token...
    15:17:55.572 Photon token acquired: bs4s3bqzwh5myqt49oh8u43kwuyaasjrhrksxsm85g9b3zpjha Authentication complete.

  • OK! I found my answer, the code doing the connection was starting in parallel with the code doing the photonToken request and was not sequenced properly, so the connection was made before the token was properly acquired. Thanks for your help and I will probably need more help in the future anyway!
  • Hi @PhilippeRenaut,

    OK.
    I'm glad you solved this.
Sign In or Register to comment.