PrecompiledAssemblyException error on upgrading Bolt to 1.2.7

I tried to upgrade Bolt from 1.2.5 to 1.2.7 and I have this error in the console that prevents me from compiling :

PrecompiledAssemblyException: Multiple precompiled assemblies with the same name Newtonsoft.Json.dll included for the current platform. Only one assembly with the same name is allowed per platform. Assembly path: {0}
UnityEditor.Scripting.ScriptCompilation.EditorBuildRules.CreateTargetAssemblies (IEnumerable`1 customScriptAssemblies, IEnumerable`1 precompiledAssemblies) (at C:/buildslave/unity/build/Editor/Mono/Scripting/ScriptCompilation/EditorBuildRules.cs:249)
UnityEditor.Scripting.ScriptCompilation.EditorCompilation.UpdateCustomTargetAssemblies () (at C:/buildslave/unity/build/Editor/Mono/Scripting/ScriptCompilation/EditorCompilation.cs:619)
UnityEditor.Scripting.ScriptCompilation.EditorCompilation.SetAllCustomScriptAssemblyJsons (System.String[] paths) (at C:/buildslave/unity/build/Editor/Mono/Scripting/ScriptCompilation/EditorCompilation.cs:728)
UnityEditor.Scripting.ScriptCompilation.EditorCompilationInterface.SetAllCustomScriptAssemblyJsons (System.String[] allAssemblyJsons) (at C:/buildslave/unity/build/Editor/Mono/Scripting/ScriptCompilation/EditorCompilationInterface.cs:217)

Any idea where this might come from ? Thanks.

Comments

  • https://doc.photonengine.com/en-us/bolt/current/getting-started/upgrading
    "Upgrading to Bolt 1.2.0.0+"
    Follow the directions here.
  • Thanks for the reply. I followed the steps : deleted all bolt related files after making a backup of the 3 files, imported 1.2.7 package but now the Bolt Wizard won't appear and I can't find it under Window/Bolt/Wizard nor in the new Bolt menu.
    I only have "'BoltLauncher' does not exist in the current context" errors in the console now.
    I tried multiple times to make sure I followed the steps correctly.
  • You may have to temporarily remove the scripts that reference Bolt launcher. Then Unity can compile and the Bolt menu and Wizard will appear.
  • A bit tidious but it worked, thanks !
    For those who have the same problem, follow these steps:
    1) Make a backup of "Assets/bolt/project.bytes" , "Assets/bolt/assemblies/bolt.user.dll", "Assets/bolt/resources/BoltRuntimeSettings.asset" and their metas.
    2) Delete all bolt related files.
    3) Import the full Bolt package.
    4) Comment all BoltLauncher references in your code (quick replace BoltLauncher to //BoltLauncher).
    5) Open the Bolt Wizard and import the core package.
    6) Reimport your backed-up files and "Compile Assembly".
    7) Uncomment all BoltLauncher references.
    8) Refresh and play to make sur everything works.
Sign In or Register to comment.