problem in connecting to local server!

i am running photon 2 as server on my pc.
when i run photon android client i.e. Photon-Android_v6-2-1_SDK using changes in server address it's working fine.

but when i am running it using localhost:5055 it's not working and giving an error that "Connection Timeout"

can anybody help me out..?

Thanks in Advance..


  • Kaiserludi
    That sounds like you have not set up you server correctly. Have installed and started instance1 as a service? What do the server logs tell?
  • Tobias
    Can you please try instead of localhost:5055?
  • We have to assign new ip of system...
  • Tobias
    Ah, right. The Android simulator uses localhost in it's own context and so you can't reach the machine it runs on.
    Sorry about that. Same applies to Windows Phone simulator.
  • I am running photon server v3 in another system. And i am using "Photon-Android_v3-0-0-0-Beta_SDK"

    I change the server IP address in the "" and also in preference, then I ran the demo app. when click on "start game" , gamefield activity get started, every thing goes fine. I just run the same demo app in another pc with the same steps. But that user is not shown in my gamefield activity.
    I checked the logcat, callback functions in the "demoservice" is not called when the new user comes in.

    Please help how to achive this.

    thanks in advance.
  • Tobias
    Both use the same string as roomname?
  • Hello, I can't connect the demo_realtime for android to local server, only to your

    i have the Photon-instance1 running and i tried to localhost:5055, and then i tried to the one that the Testclient runs on,

    testclient goes well and does the 25 rooms with 4 people each. but when i try to connect the android java demo it gives "TimeoutDisconnect! peer.state: 1".

    what's happening?

    and no i didnt forgot to close the testclient before running the demo, or else the slots would be full, i've tried doing before the testclient, then run the testclient to test the IP, then close the test client and try again with demo, still nothing.
  • dreamora
    Options is the wrong address, you need to specify the address of the machine within the lan, would be your android device / emulator