Unity 2019 Beta: Prefabs with Photon View components are breaking

Hello,

I was just wondering if anyone else has tried pairing PUN 2 with the Unity 2019 beta. I seem to be having issues with the prefabs that I save for instantiation inside of my resources folders being broken (only occasionally, and only prefabs with the photon view component).

Unity doesn't allow them to be dragged into the scene and causes a whole host of problems that I'm afraid I don't really understand.

I would be happy to post more specific error messages if it would be helpful.

Thanks!

Comments

  • Hi @Dubada01,

    Thank you for choosing Photon!

    PUN2 does not officially support Unity 2019 beta.

    Could you try the fix from this post? It could be related.
  • Are you on the latest PUN 2 version from the Asset Store? We fixed a few things regarding the new prefabs workflow.

    We will check if we can reproduce and fix what you describe.
  • Hi,

    I just tested, and it all looks good: https://i.imgur.com/OH8CnIh.png

    - Can you clarify what goes wrong, and paste the error messages you get or what are the signs that something odd is happening?

    - have you tried the demos provided, do they work fine for you?

    Bye,

    Jean
  • Hi
    Thank you for your solution,
    I have this issue with PUN 2.6 and it had been solved with Pun v 2.9.
  • JohnTube said:

    Hi @Dubada01,

    Thank you for choosing Photon!

    PUN2 does not officially support Unity 2019 beta.

    Could you try the fix from this post? It could be related.

    Do you have any near future plan to support Unity 2019 with .net 4 runtime. Right now i am using unity 2018 but want to shift 2019 as soon as possible for it's new exciting feature.
  • We will support 2019 in PUN v2.10. The new runtime should not need special attention, as far as we know.
Sign In or Register to comment.