The Photon Forum
is Closed Permanently.

After many dedicated years of service, we have made the decision to retire our Forum and switch to read-only: we´ve saved the best to last! Your search result can be found below. Plus, we offer support via these channels:

Try Our
Documentation

Please check if you can find an answer in our extensive documentation on PUN.

Join Us
on Discord

Meet and talk to our staff and the entire Photon-Community via Discord.

Read More on
Stack Overflow

Find more information on Stack Overflow (for Circle members only).

Write Us
an E-Mail

Feel free to send your question directly to our developers.

How to test game on one pc

Jaudatus
2018-12-03 15:15:32

Hi there,
how can i test my networked game on one pc? When I build a version and run a second instance in the editor i can't connect to the same room? Both instances create a new room.

Any advice?

Greets

Comments

Captain_Pineapple
2018-12-03 22:04:25

Hey there,
perhaps check your router for possible blocked ports. (the list of ports is here
If that does not help try if the demos are working. If they are not doublecheck if you got all your settings in the photonserversettings right and that there is no local firewall blocking your programm.

Jaudatus
2018-12-05 12:47:07

Hi @Captain_Pineapple,
thank you for the answer. I allowed all required ports in the router and disbaled my local firewall.

When I open up two builded versions I can see the created room and successfully connect to it but when I open one builded version and the other one in the unity editor it's not working.

Seems to be a problem with the unity editor. I allowed port 843 for the unity policy.

I also tried switchting the photonserversettings protocol from UDP to TCP.

Same result with the demo projects.

Some ideas?

Greets

SadorCorvus
2018-12-05 13:37:15

I have the same issues. But three days ago, everything worked fine :-(

JohnTube
2018-12-05 20:02:37

Hi @Jaudatus, @SadorCorvus,

Thank you for choosing Photon!

Go through our "Matchmaking Checklist" carefully.
Maybe the Unity Editor and the build are not connected to the same region or have different AppId/AppVersion etc.

Captain_Pineapple
2018-12-06 06:58:07

Indeed what John said.
Just had the same problem, when i set a fixed App Version and a fixed Region in my PhotonServerSettings everything worked fine again.

Jaudatus
2018-12-06 07:52:10

@JohnTube @Captain_Pineapple
Thank you for the reply. I set a fixed region in the PhotonServerSettings and now it's working fine :smile:

@SadorCorvus maybe you want to do the same.

SadorCorvus
2018-12-06 10:20:27

Thank you sooo much! That made my day!
I really have no idea why it worked first and I ran in that problem...

JohnTube
2019-08-28 12:00:50

Hi all (@SadorCorvus, @Jaudatus, @Captain_Pineapple),

see "[PUN2] Best Region: investigation and improvements".

Back to top