"[PhotonCloud] Disconnected" in sample level

I'm trying to test out Bolt's Advanced Tutorial scene, but every time I try to play as server I'm greeted with this:

I had no issues with the basic tutorial, and I've followed the Advance Tutorial so far to a tee, but I just can't get this to work. I've tried searching around for similar issues and only found suggestions to: turn off my antivirus, change Bolt connection mode from Auto to Manual, and to change my region in Bolt settings. I've done all of this and nothing is fixing it.

I'm able to connect maybe 10% of the time, but then it disconnects about a second after loading the scene. Am I missing something? Does anyone have any other fixes for this issue?


  • Are you doing "Debug start" or using BoltInit.cs? What Bolt version are you on?
  • stanchion said:

    Are you doing "Debug start" or using BoltInit.cs? What Bolt version are you on?

    I've been trying with both, and Boltinit seems to be very slightly more reliable. I'm using Bolt Free from the asset store.
  • Does it work if you disable punch?
  • @Wschmidth can you try to disable the punch in the Bolt Settings and test it again?
  • WschmidthWschmidth
    edited October 2018
    Sorry for the late response, wasn't able to work on this throughout the weekend.

    I tried disabling punchthrough and got similar results.

    I also tried swapping the connection mode from photon cloud to custom hosted and I get this:

    Both these screenshots were from trying with Debug Start, but I get the same results from creating a build.
  • Have you registered all Tokens that you are using? The error says that are missing the registration of `ServerAcceptToken` in one of your clients.
  • Sorry, tokens? I don't think I've seen that term anywhere.

    Also, did Photon Bolt update on the Asset Store? I thought I'd try from scratch on a new project, but Importing the asset from the store no longer gives me the sample projects.
  • Thanks, I forgot about the Wizard, for some reason it didn't show up automatically at the start this time.

    Anyway, I tried it again in a new project and it worked fine. I must have done something wrong with the Wizard on the last project, but even after going through the Wizard a second time in the old project it didn't fix anything. So I guess my issue is solved, just hope I don't come across something like this again further into a project.
Sign In or Register to comment.