The Photon Forum
is Closed Permanently.

After many dedicated years of service, we have made the decision to retire our Forum and switch to read-only: we´ve saved the best to last! Your search result can be found below. Plus, we offer support via these channels:

Try Our
Documentation

Please check if you can find an answer in our extensive documentation on PUN.

Join Us
on Discord

Meet and talk to our staff and the entire Photon-Community via Discord.

Read More on
Stack Overflow

Find more information on Stack Overflow (for Circle members only).

Write Us
an E-Mail

Feel free to send your question directly to our developers.

How Disable or greatly increase ServerDisconnectTimeout? PUN

dmitrii
2018-08-09 12:38:19

With poor Internet I get a lot of disconnects by timeout. I increase client timeout, count allowance and quickresetannempts and this error disappeared.

But I get disconnect by server timeout error too, how do I raise this value? Photon Cloud, without a photon server. SendRate = 20

Comments

[Deleted User]
2018-08-09 13:06:25

Hi @dmitrii,

if you haven't done this already, I'm asking you to check the Analyzing Disconnects documentation page and see if you get some helpful tips there.

I guess increasing the DisconnectTimeout value does not work in this case, because you can't change this value on the server. The server might also disconnect a client, if ACKs messages get lost on the way.

dmitrii
2018-08-09 13:55:29

@Christian_Simon
Thank you! I have already read Disconnected Analyzes and checked all the options.

I reduced the number and frequency of the RPC, it did not help. I checked that the packets do not disappear through the CRC filter - the losses are 0. But sometimes, the Internet is lagging and the photon is immediately disconnected, but it is necessary that he wait until the Internet is available and continue the game. Early i geted ClientTimeout, but now i increase client timeout time and now i get serverTimeout.

Back to top