Error while launching PhotonControl.exe

edited December 2011 in Any Topic & Chat
Hi,

I'm seeing the following error when I try to launch PhotonControl:

System.IO.FileNotFoundException: Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.
File name: 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'
at PhotonControl.ControlForm.ActiveProcessCount(String processName, Int64& memory)
at PhotonControl.ControlForm.SetEnabledMenuItems()
at System.Windows.Forms.Timer.OnTick(EventArgs e)
at System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

This is a new machine that I just setup on AirVM. Does anyone know how to fix this?

The specs on the machine are:

Win2k8 64-Bit
2 CPU @ 1000MHZ / CPU
(Total CPU: 2000MHz)
2 GB RAM
25 GB Production Storage

I followed the instructions for installing at http://doc.exitgames.com/v3/quickstart/ ... iveminutes.

Any help is great appreciated, thanks!!

Comments

  • The System.Core assembly is missing (not found), which most likely means you didn't install the DotNet runtime. Get the latest one, install and try again.
    For Photon, you need this runtime anyways, so it's not just the PhotonControl.
  • Hi Tobias,

    I thought maybe I installed something wrong so I gutted the VM and started over. With a new VM, I went in and installed just the latest version of the .NET framework (http://www.microsoft.com/download/en/de ... x?id=17851). With nothing else running, I proceeded to try and install Photon again and I'm still getting the same error.

    I've seen other people use AirVM with Photon before so I know it works...I just don't know why it doesn't work for me. On a side note, I have Photon running on my EC2 instances for months now with no issues.

    Do you have any other ideas as to what else might be wrong?

    Thanks!
  • You should install the .Net Framework 3.5 SP1 also.
    Here is a post which descripes the problem.
    http://social.msdn.microsoft.com/Forums/en-CA/netfxsetup/thread/4f0b7821-506f-453f-896e-54a545c75081

    We will try to remove the code which causes this dependency to the 3.5 framework in future versions.
  • Thanks BenStahl, your suggestion worked! In case anyone else runs into the same problem with AirVM or other cloud services, I added the role and features required to get .NET installed, ran .NET 3.5SP1, and then installed .NET 4 along with all necessary windows updates.

    Guess I was a little spoiled with EC2 when everything just worked...
Sign In or Register to comment.