Thunder Getting started problems


I know it just came out, but has anyone managed to successfully install Thunder on their project yet?

For me the issues are related to read/write access to Unity's installation folder, so the copying over of files doesn't work during Thunder -> Install (or Uninstall for that matter).

Also, do we have a thunder slack chat / dedicated forum somewhere that I haven't seen for getting extra info fast?


  • That might be an issue indeed. Can you try to run Unity with admin privileges and then install? This should fix the issue and enable the installer to backup/replace the needed files.

  • Hello,
    Are you trying to install in which Unity version ? What is your OS ? Did you tried to run Unity as admin ?

    Ramon Melo
    Thunder Developer
  • So,

    Unity 5.6.2p4, Windows 10 64bit.

    Unity without admin -> Can't copy anything, not even the version.txt file
    Unity with admin -> Copies a few files, gets stuck when copying dll's. With an install and an uninstall I was left with a broken Unity installation.

    Worked around it by giving the installer a folder in an accessible folder (not under Program Files), copying over the Shared and UnityExtensions/Unity/Networking folders and then running it. After succesfully installing, I manually copy the folders over to Program Files and overwrite the originals.

    I've received support since then, and it's my understanding that this is fixed in v104. Haven't tried as I can't risk another Unity-wide issue at this time (couple of deadlines coming up).
  • Me too. Unity 5.6.2p4, Windows 7 64bit. I can't tell if all files are being copied, but something happens because networking is broken after I restart Unity and Thunder doesn't seem to be fully installed. I had to uninstall/reinstall Unity to get things working again. I'll wait until there's a better solution for this before I try again. Perhaps if there were directions for manually installing, moving, baking up files that the installer does, I'd do it myself and see where the problems start.
Sign In or Register to comment.