Photon Voice not loud enough.

Hey there.
I'm using Photon Voice with Oculus Rift and HTC Vive and I've run into a problem with loudness. The voice chat is borderline unhearable .

I've checked the Rift and Vive microphones on both machines to make sure they are running with max sensitivity. I made sure that Photon Voice audiosources are set to 2D to remove any spatial falloff. The volume is set to 1 (max in unity). I tried running calibration after the player prefab is spawned, but this changes nothing. I've reduced the volume of all other audiosources in my game by 0.5, but this is still not enough to make the voicechat clearly legible.

Is there a way I can increase the volume of the Voice Speaker? It would be best if there was a multiplier of base setting, kinda like PlayOneShot works in audio source.

Comments

  • vadimvadim admin
    Hi,
    You can "amplify" data in audio buffer before passing it to Photon Voice.
    The simplest way is modifying MicWrapper.GetData method. Multiply each element of buffer after this.mic.GetData(...) call by amplification factor.
    Or use this approach http://forum.photonengine.com/discussion/comment/32592/#Comment_32592

    We changed Photon Voice "internal" api. So both solutions should be updated with next Photon Voice release. Sorry for that.

    PhotonVoiceRecorder.LevelMeter allows measure current audio signal level passed to PhotonVoice.
  • Thanks a lot Vadim, I did just that.

    Would love to have amplification factor as a property I can edit in future Photon Voice version.

    Cheers.
  • Hi,

    I have the exact same issue with HTC Vive. Would you mind sharing your coding for the amplification?
Sign In or Register to comment.