Voice is sometimes working and sometimes not working

edited February 4 in Photon Voice
I'm using photon voice 2.3 and its working sometimes and not working sometimes and the prefab for the speaker is instantiated in the client system and it gets disappeared automatically. Can I know how to fix this? and it's not showing any errors.

Comments

  • Hi @Arivazhagan,

    sometimes working and sometimes not working
    We can't help you with this only, we need more info.
    it gets disappeared automatically. Can I know how to fix this?
    Do you use Photon Voice 2 without PUN? You use VoiceConnection component with SpeakerPrefab? if so then yes the default behavior deletes Speaker prefab once the remove voice stream is removed (Recorder deleted, disconnected, etc.).
  • Thanks for the reply. I'm using Photon Voice 2 with PUN and I have separate prefabs for voice connection and speaker.
  • Is anyone there?
  • Hi @Arivazhagan,

    Yes.
    We need enough information about the issue to be able to help.
    Provide details about the environment and clear steps to reproduce the issue.
    Otherwise we can't do much.
  • hey, @JohnTube
    I'm using the updated version of photon voice. when I play the game it creates prefab like #player for speaker 1 like that. In between my game, it automatically gets disappeared sometimes. So the voice connection between the clients is not able to communicate with them, because of that speaker thing is getting missed. In my case, I'm using the microphone type as photon.

    If you need any information other than this I'm ready to give.
  • Hi @Arivazhagan,

    Send us a minimal repro project by exporting a unitypackage.
Sign In or Register to comment.