Photon Transfer View Position won't uncheck

I have a gameobject, and i don't know why, but whenever I uncheck position under synchronize options,
like so:


It simply doesnt work in game, and whenever I go back to check on it, like magic..


It just goes back to being checked..

Comments

  • Also this seems to be the case for every object I put it on.
  • Are you sure there ain't no prefab connections?
    Original prefab might reset to default settings on scene start. Try changing values in prefab.
  • I am changing the values on the prefab, also its not even scene start, i just have to click on something else then click on it again.
    Never really seen a bug like this, dont know if its more of a unity thing or a Photon thing, but this is the only script ive had this happen to, and its quite game-ruining.
  • Which version of Unity you are using? 2018.3 introduced nested prefabs, perhaps it's messing up with photon. It could be Unity bug as well as it is a new feature.
  • I am using 2018.3, not sure what nested prefabs are, ill look into it
  • I found a solution to the problem, in case anyone is having a similar issue.
    I was doing all my edits of my prefab in the new prefab editing mode, which has an auto save feature, however, apparently this mode does save checking things on or off, it simply doesnt register those changes.
    To fix the problem, i had to just drag my prefab into a scene, uncheck the position box, and apply override.
    This has fixed my issue, hope unity fixes this oversight soon.
Sign In or Register to comment.