Photonserver starts and immediately crashes on win2016 server

Hi all
OS = Windows server 2016 64 bits
Photon On Premise Server SDK v4-0-29-11263
.Net Framework 4.6 and 3.5 installed
(if some of you want to know how to install .Net Framework 3.5 on win 2016 server , just ask me)

When I launch ...\deploy\bin_Win64\PhotonControler.exe , I get (almost immediately 'Photon stopped'

CLR log shows
2018-08-22 17:06:15,095 [ 1] INFO PhotonHostRuntime.PhotonDomainManager - Getting license information:
2018-08-22 17:06:15,189 [ 1] ERROR PhotonHostRuntime.PhotonDomainManager - Failed to get PhotonLicensing instance: Exception has been thrown by the target of an invocation.
2018-08-22 17:06:15,189 [ 1] ERROR PhotonHostRuntime.PhotonDomainManager - ERROR: failed to load PhotonLicensing.dll. Going to shutdown.

What I've tried
To do the same on win10, win 2012 server : it works

I corrupted the PhotonLicensing.dll to identify if the file could be found and read
In this case CRL log shows
2018-08-22 18:04:13,446 [ 1] INFO PhotonHostRuntime.PhotonDomainManager - Getting license information:
2018-08-22 18:04:13,462 [ 1] ERROR PhotonHostRuntime.PhotonDomainManager - Failed to get PhotonLicensing instance: Could not load file or assembly 'PhotonLicensing.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.
2018-08-22 18:04:13,462 [ 1] ERROR PhotonHostRuntime.PhotonDomainManager - ERROR: failed to load PhotonLicensing.dll. Going to shutdown.


Nota : PhotonLicensing.dll file is not 'blocked'

No additional relevant info in the Photon-loadbalancing log

Please advise .
I can't change my server which needs to run win2016 server.

Thanks

Comments

  • Hello,

    please check if the second hint from this page helps: http://forum.photonengine.com/discussion/5029/photon-server-sdk-3-4-known-issues
  • Hello
    Thank for your reply
    The second hint is about the 'blocked' file . It was the first thing I checked .
    Nota : I have had the opportunity to try to install PhotonServer on another win 2016 server machine .. it worked
    However the builds between the two win 2016 server machines are a little bit different .
    Do you know if there is some specific requirements regarding win features (for example) ?
    Thank
  • hi, @absolute_beginner

    there is not anything really specific. Maybe .net for required to be installed

    but that is it. Use build which works for you

    best,
    ilya
  • Hi
    If that could be so easy :) To make the build changed will take a while (at least one month)


  • Hi all
    Solution found whitout rebuilding the machine
    There is a key in the registry which didn't have the right value
    HKLM\System\CurrentControlSet\Control\Lsa\FipsAlgorithmPolicy\Enabled must have 0 as value

    Kind regards
  • @absolute_beginner good that you found this.

    this will help us to resolve issues later

    best,
    ilya
Sign In or Register to comment.