Photon and Unity 2018.2.2

Hi, I got this error when I tried to update Unity to 2018.2.2.

Updating Assets/Photon Unity Networking/Editor/PhotonNetwork/Views/PhotonAnimatorViewEditor.cs - GUID: a3f61bade114730459f7ad45f5f292c1...
Invalid #ifdef expression: UNITY_5 || UNITY_5_0 || UNITY_5_3_OR_NEWER (error around

Comments

  • Unity hangs on "importing scripts.." and spams "Invalid #ifdef expression: UNITY_5 || UNITY_5_0 || UNITY_5_3_OR_NEWER (error around" error in Editor.log
  • I'm seeing the same in Unity 2018.2.2f1.

    This only happens when doing a full clean recompile (after deleteing the Library folder)

    I've worked aroun d the issue by wrapping all the "#elif UNITY_5 || UNITY_5_0 || UNITY_5_3_OR_NEWER" in brackets:

    #elif (UNITY_5 || UNITY_5_0 || UNITY_5_3_OR_NEWER)

    No idea why this would work when the original didn't
  • Hi @romanmultan @QualityJohn

    Thank you for choosing Photon!

    I did a fresh import in a clean project of PUN 1.91 inside Unity 2018.2.2f1 and I didn't get any errors.
  • fresh import of 1.91 into 2018.2.3f1 running under Ubuntu Linux hangs and fills Editor.log with
    "Invalid #ifdef expression: UNITY_5 || UNITY_5_0 || UNITY_5_3_OR_NEWER (error around " errors
  • seems the importing issue is caused by an extra white space at the end of line 23 in Photon\ Unity\ Networking/Editor/PhotonNetwork/Views/PhotonAnimatorViewEditor.cs
  • We've just done an update of Photon to v1.91 and this issue came back as the update overwrote our local fix.

    I can confirm what @NeoCortex said that it's being caused by the extra whitespace at the end of line 23.

    Could you fix this in the source so it doesn't break again the next time we update?
  • We have removed the extra white space, it won't be there in the next version.
    Sorry for the inconvenience.

    As my colleague @Tobias said:
    Should be reported to Unity as bug.
    This is then different in Linux than in Windows or Mac (or compared to older versions).
Sign In or Register to comment.