Assets/Plugins/PhotonLoadbalancingApi/LoadBalancingClient.cs(2563,48): error CS1501: No overload for

With the new Unity 2018.2 and the June 6 PUN I am getting this error.

Assets/Plugins/PhotonLoadbalancingApi/LoadBalancingClient.cs(2563,48): error CS1501: No overload for method `InitDatagramEncryption' takes `3' arguments

The line of code is this.
this.loadBalancingPeer.InitDatagramEncryption(secret1, secret2, mode == EncryptionMode.DatagramEncryptionRandomSequence);

Comments

  • Hi @ktweedy1,

    Thank you for choosing Photon!

    Could you update to latest PUN version 1.91 and try again? It should work with Unity 2018.2.
  • ktweedy1ktweedy1 ✭✭
    Hi, the June 6 release is version 1.91.
  • Hi @ktweedy1,

    You mean July not June.

    You probably updated and imported PUN inside Photon Voice.
    That is not supported.
    You should use PUN version inside Photon Voice.
    We will release a Photon Voice version that includes PUN 1.91 this week.
  • ktweedy1ktweedy1 ✭✭
    I was able to recreate what is happening.

    I am using PUN, Chat and Voice. So when I updated to June 1.91 I also got the current Photon Voice from May. This gave the following error. Photon Voice has PUN in it so looks like you Photon Voice hasn't been updated for 2018.2

    Assets/Photon Unity Networking/Editor/PhotonNetwork/PhotonEditor.cs(675,46): error CS0619: `UnityEngine.RPC' is obsolete: `The legacy networking system has been removed in Unity 2018.2. Use Unity Multiplayer and NetworkIdentity instead.'

    So I then import 1.91 again and when I did that I got this error.

    Assets/Plugins/PhotonLoadbalancingApi/LoadBalancingClient.cs(2563,48): error CS1501: No overload for method `InitDatagramEncryption' takes `3' arguments

    So I am confused on what to do. And I haven't seen some documentation on what your installation of Photon Voice. Do I install PUN first then voice. Do I just install PUNVoice and not need PUN? I am also using Photon Chat and your PUN Chat says to not install since it is already included in PUN.
  • JohnTubeJohnTube mod
    edited July 11
    Hi @ktweedy1,

    Sorry for the inconvenience.

    PUN inside Photon Voice was stripped from Photon Chat API and demos.
    So to make Photon Chat work inside Photon Voice import it partially (Only "Assets\PhotonChatApi" folder) from PUN, from Chat package on the store or from Photon Unity SDK.

    So you should clean up Photon assets, import Photon Voice then Photon Chat only from one of the sources mentioned above.

    You should also always use a version control system.

    As I told you we will update Photon Voice soon with PUN 1.91 inside.
  • Hi @ktweedy1,

    FYI: We released Photon Voice 1.16 today (might take some time before it appears on the store while it's being reviewed) which includes PUN 1.91v.
Sign In or Register to comment.