PUN broken in Unity 2018.2.0b8

Upgraded to Unity 2018.2.0b8 and now I get this and nothing compiles:

Assets/Photon Unity Networking/Editor/PhotonNetwork/PhotonEditor.cs(675,46): error CS0619: `UnityEngine.RPC' is obsolete: `The legacy networking system has been removed in Unity 2018.2. Use Unity Multiplayer and NetworkIdentity instead.'

Any idea when this might be fixed? Thanks

Comments

  • Hi @gevarre,

    sorry for the inconvenience and thank you for your report. As a first try to solve this issue you can try to remove the code lines which are throwing these error message (you can basically comment the entire if-condition). I currently don't have this version installed, so I can't test it myself. If you notice any unwanted side effects, please let us know.

    Any idea when this might be fixed?


    We will fix this issue with the next PUN version. Sadly I can't give you any ETA about this version.
  • I have the same issue. I hope it will be fixed soon!
  • Hi @RZ_Games,

    Thank you for choosing Photon!

    Did you update to latest PUN 1.91?
Sign In or Register to comment.