Secure Web Socket - No credentials are available in the security package

Hi, when starting photon server with WSS configuration server don't start and says "No credentials are available in the security package"

At first i had problem with certificate cause it was installed in user profiles not computer profiles. But after resolving that i got this error which don't say much


  • Figured it out, you can't use just .crt file, you need to create .pfx which is .crt combined with .key

    How to create pfx:

    after this, server loads
  • Hi @Horkyze,

    Thank you for choosing Photon and for posting your finding here!

    We should probably add all useful info for WSS setup to this docs page.
    If you have any other suggestions let us know.
  • HorkyzeHorkyze
    edited January 8
    @JohnTube Is it even posible to test WSS with self issued certificates?
    and FireFox show Cannot connect to .. and server shows this in Log

    16860: 14:13:12.331 - CTCPWebSocketServer::OnError() - CFilteringStreamSocketConnectionManager::FilterReadCompleted() - Exception: CClientContext::DecryptData() - The certificate chain was issued by an authority that is not trusted.

    im on localhost btw

  • Yes, this was changed in recent versions of the two browsers.
    If you want to avoid those warnings, try one of the solutions from this link. Like this script.
  • HorkyzeHorkyze
    edited January 8
    Thx that solved it. Most important info is line 6 from that script
    IMPORT THE .crt FILE INTO CHROME Trusted Root Certification Authorities

    So, export or create .pfx certificate and then
    Chrome->Settings->Advanced->Manage Certificates->Trusted Root Certificate Authorities -> Import
Sign In or Register to comment.