Photon demo particle doesn't work in 4.18 UE4


I tried to run demo particle following the instructions below but it doesn't work.

So this is what I have done so far:
1. I already have UE4 SDK 4.18
2. I downloaded photon sdk for Android
3. I followed step 4 and copied android sdk to specific folder within source/photon/lib folder
4. I opened context menu by right click on ./PhotonDemoParticle.uproject and chose "Generate Visual Studio project files
5. I then tried to build Games/PhotonDemoParticle

And I'm getting the error below

C:\Program Files\Epic Games\UE_4.18\Engine\Build\BatchFiles>Build.bat PhotonDemoParticleEditor Win64 DebugGame "D:\Projects\Unreal\PhotonDemoParticle-UE4\PhotonDemoParticle.uproject" -waitmutex
Using 'git status' to determine working set for adaptive non-unity build.
WARNING: D:\Projects\Unreal\PhotonDemoParticle-UE4\Source\PhotonDemoParticle\PhotonDemoParticle.Build.cs: warning: Module constructors should take a ReadOnlyTargetRules argument (rather than a TargetInfo argument) and pass it to the base class constructor from 4.15 onwards. Please update the method signature.
Compiling game modules for hot reload
Performing full C++ include scan (no include cache file)
ERROR: One or more of the modules specified using the '-module' argument could not be found.


  • Hi @lens.

    We have just released an update to Photon UE demo project, that makes it compatible with UE4.18.

    Please re-download the demo zip and try again
Sign In or Register to comment.