Forum bugs

edited June 2017 in Any Topic & Chat
I was trying to add post at this topic: http://forum.photonengine.com/discussion/9314/explain-how-to-use-byte-code-on-photonpeer-registertype#latest

- When i use post edit twice, my post vanish (when i click accept edit). It happens 10 times for me, its rly annoying. I'm writing post by 15-30 minutes (with editions) and... booom vanish, destroy, my 30 minutes goes to trash (there is hack for it, you have to press cancel and somehow post is restored from cache, but you have to copy it and post again).
Bug screen shot:

- After few bugs like that, I'm getting message "Your comment will appear after it is approved" nice... rly nice support guys

That is the post:

I'm trying to add custom serialization method for class "a".
Class "a" contains Vector3 field, which I need to serialize.
I want use Vector3 serialization method to achieve that (DRY standard), which is defined in CustomTypes, but this method is private.
I don't wan't to modify code provided by Exit Games (CustomTypes.cs and PhotonNetwork.cs - where CustomTypes.Register() is called - are provided by Exit Games).

How can I provide serialization method for class "a", without breaking DRY standard or modify Exit Games code?
Is there any method, that can I call, for already defined custom types? It would be usefull, because calling serialization method directly, also isn't perfect idea... its only acceptable.
Something like "Protocol.Serialize/outStream.Write(Registered type that photon can serialize)"

Edit: I need also to serialize String field in class "a", photon can serialize that type, but I'm forced to conver string to bytes on "my own hand"? Seriously?

I would like to notice, that:
- serialization methods in "CustomTypes" class are private, but buffors associated with those methods, are public XD - there is no logic in that.
- CustomTypes.Register() is called from Exit Games code - it's bad. Custom types are tool for developer, so developer should decide about custom types registration.
- Using char, to register custom types, is rly, rly, rly bad - developer have to remember, which chars was used, it should be done like this (without handling chars):

- Your code section (forum) is creepy
- When i use post edit twice, my post vanish (when i click accept edit). It happens 10 times for me, its rly annoying. I'm writing post by 15-30 minutes (with editions) and... booom vanish, destroy, my 30 minutes goes to trash (there is hack for it, you have to press cancel and somehow post is restored from cache, but you have to copy it and post again).
Bug screen shot:

- After few bugs like that, I'm getting message "Your comment will appear after it is approved" nice... rly nice support guys

Comments

  • I told JohnTube about this bug in March. Seems that nothing has been done to fix bug :/
  • Hi @ostryjagoda @OneManArmy,

    I apologize about the inconvenience.
    The forums are powered by Vanilla.
    If you can help us have clear reproduction steps and a link to the posts or discussions where the issue happened it would be great.
    So my colleague @Markus can get in touch and report this to Vanilla directly.
  • Hi,

    Vanilla uses Akismet as spam filter. Your comments had been marked as spam (hinted by the message: "Your comment will appear after it is approved"). They have been approved now. Also, your user has been approved, so you should not see that again in the future.

    Regarding your other description "When i use post edit twice, my post vanish (when i click accept edit)", I am sorry, but I do not understand the steps you do. This is the same issue or a different one? Could you add clear reproduction steps, please? (incl. used browser and any blocking add-ons, if present)

    Thanks
  • edited July 2017
    @Markus At first - somebody accept all my posts, without checking it.
    I was quite angry, and try bruteforce method (clicking "post comment" one milion times, which was probably registered as unique posts) XD.
    There is few duplicates now - can you check it?

    "Regarding your other description "When i use post edit twice, my post vanish (when i click accept edit)", I am sorry, but I do not understand the steps you do. This is the same issue or a different one? Could you add clear reproduction steps, please? (incl. used browser and any blocking add-ons, if present)"
    This is the same issue. I'm using chrome browser, without any mods.
    - Create post
    - Edit it
    - Edit it again

    I'm not sure how it works, because it is not happening now.
    Just try to use edit option in bruteforce way, maybe this bug occures also for you.
    It was happening in any topic (there is no "special" topic, that causes this bug).

  • Thanks for the update.

    If it is the same issue, this most likely is caused by the system treating it as spam.
    Your post shows repeatedly, as each time you saved it, it got saved, but marked as spam. In the meantime, those posts have been approved, so they all show up now.

    Will check, if we can update the spam message.
Sign In or Register to comment.